Обозначим через ДЕЛ(n, m) утверждение «натуральное число n делится без остатка на натуральное число m».
Для какого наименьшего натурального числа А формула
(ДЕЛ(x, 2) → ¬ДЕЛ(x, 3)) ∨ (x + A ≥ 100)
тождественно истинна (т. е. принимает значение 1) при любом натуральном значении переменной х?

def f(x, A):
    return ((x % 2 == 0) <= (x % 3 != 0)) or (x + A >= 100)
for A in range(0,100):
    if all(f(x,A) for x in range(1,100)):
        print (A)

Приведём другое решение на языке Python.

for A in range(1, 101):
    k = 0
    for x in range(1, 1000):
        if ((x % 2 == 0) <= (x % 3 != 0)) or (x + A >= 100):
            k += 1
    if k == 999:
        print(A)
        break